Good Run Guide

WEBSITE

Upload Speed/freezing

Average RatingAverage RatingAverage RatingAverage RatingAverage Rating
AVERAGE RATING

Started by : Victoria Nealon on 04/04/13

Viewed : 3836 times

 

Total Posts : 19  (Oldest First)   Show Most Recent First
Photo View Member Profile Victoria NealonView Member Profile Member since August 2010 Posted 8 years ago
 0

I don't know if anyone else has experieced this or not.  But I've been finding a lot recently when I upload my runs from my garmin 210 it seems to take ages for the run to be uploaded.  Also, once it is uploaded and I've saved it, I then find that the website seems to freeze/crash as soon as I try and move to a different page e.g. back to my home page, or my log book etc.  This happens pretty much every time i upload a run and my laptop will then tell me that the website is not responding...  Has anyone else experiened this or got any suggestions? I don't have the same trouble with uploaded to other sites such as garmin so I don't think it's my computer or internet speed...

 
Photo John at GRGView Member Profile Member since February 2006 Posted 8 years ago
 0

Hi Victoria - can I ask, are you using the Upload from FIT File tool or the main Garmin Upload tool?  And do you have a lot of runs on your GPS device?

Anyone else having problems like this?

John

 
Photo Liz DiamondView Member Profile Member since April 2011 Posted 8 years ago
 0

I have noticed the uploading has taken a little longer than normal over the last couple of days, and it can be a bit tempremental when going back to the home screen after it has uploaded freezing for maybe 10 secs. Normally it all flows in secs, i thought it was my computer but it might be a similiar problem to Victoria.

i'm uploading from my 310xt which has runs/rides deleted as soon as uploaded so an empty memory, hope this helps find the issue for this great site.

 
Photo Marilyn Hunt Member since December 2012 Posted 8 years ago
 0

My 110 upload used to freeze every time I tried to upload so I gave up and now use the FIT upload tool instead (works every time)

 
Photo John at GRGView Member Profile Member since February 2006 Posted 8 years ago
 0

Can you let me know what browser you are using please?  And does it freeze when you try to leave the page or before this?

Liz - Did you upload a run yesterday?  Do you remember what time it was approx?  I'll have a look at the log files to see if there was anything unusual going on at that time.

 
 
 
Photo View Member Profile Victoria NealonView Member Profile Member since August 2010 Posted 8 years ago
 0

I upload by just connecting my garmin and clicking to upload from gps device.  There probably are a few runs on my device but I upload each one after I've ran so there's only one new one at a time.

In terms of browser I use safari (as I have a mac).  It just takes ages to upload (which it does eventually do) then freezes when I try and leave the page to go to a different one once I've saved the run.

 
Photo John at GRGView Member Profile Member since February 2006 Posted 8 years ago
 0

I think the problem may be partly caused by memory leaks.  We've made a few tweaks to the code to try to address this, so hopefully you will notice an improvement.  Let us know. 

It's also worth closing and restarting your browser if you start to experience sluggish performance as this will flush out any memory leaks.  I'd be interested to know if you keep GRG open all the time or whether you close your browser (or the tab) after using it.

If you've not already done so, setting your Garmin device to use Smart Recording rather than Per Second recording will also reduce the amount of data that the application has to handle and should speed things up.

 
Photo View Member Profile Victoria NealonView Member Profile Member since August 2010 Posted 8 years ago
 0

I'm just about to upload a run now so shall see how I get on and let you know.  I do tend to close the tab for GRG although my browser is often left open so don't know if that would make a difference?  I'll check the garmin too (if I can figure out how) to see how it's set up.

 

Thanks

 
Photo View Member Profile Victoria NealonView Member Profile Member since August 2010 Posted 8 years ago
 0

Just tried uploading my run, took from when I posted below to now (so about 15 minutes...)  Took at least 7-8 mins to read the run from my garmin, which is where is always seems to be slow.  Saves it fine and then when I tried to go back to the home screen it froze again, and then told me that the webpage was not responding, so had to force re-load which then means I have to log in again.  Wasn't even a very long run as I would expect that to take longer to download all the data...

Vicky

 
Photo John at GRGView Member Profile Member since February 2006 Posted 8 years ago
 0

That's not good - I was hoping that changes I made would have helped.  If it takes 7-8 minutes to read the data from your garmin device that is an awfully long time, so I think that must be the root cause of the problem.  Mine reads in under a minute.  When you click Read GPS, it reads all the data on the device, so if you have a lot of data being transferred this could be causing the page to hang when you try to move off the page.  Can you delete some of the data from your device? How many runs does it show in the list after you have pressed Read GPS?

Just had a quick look at the manual for the 210 and it appears that there is no option for Per Second recording (it uses Smart Recording by default), so this is not something to worry about.

 
Pages: 
 
 
 
Good Run Guide Good Run Guide - The UK's Leading Independent Running Website
About Us
Link to Good Run Guide
Contact Us
Copyright ©2006-2021 Good Run Guide Ltd. All Rights Reserved  |  Terms and Conditions  |  Privacy Policy